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Создание проекта в среде Proteus

Добавление компонентов схемы

Демонстрационное видео 
добавления компонентов схемы 

в проект
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Создание проекта в среде Proteus
Результат добавления 
компонентов схемы



Зеркальное отражение 
компонента
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Создание проекта в среде Proteus



Запуск редактирования свойств 
компонента
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Создание проекта в среде Proteus
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Создание проекта в среде Proteus
Редактирование свойств компонента



Результат зеркального 
отражения и редактирования 
свойств компонентов схемы
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Создание проекта в среде Proteus
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Создание проекта в среде Proteus
Добавление шины к схеме
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Создание проекта в среде Proteus

Соединение проводниками компонентов 
схемы и линий шины
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Создание проекта в среде Proteus

Установка метки соединения
Нажать на правую клавишу мыши

 в указанной области
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Создание проекта в среде Proteus

Установка метки 
соединения
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Создание проекта в среде Proteus

Установка метки соединения
Нажать на правую клавишу мыши

 в указанной области
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Создание проекта в среде Proteus

Установка метки 
соединения
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Создание проекта в среде Proteus

Результат промежуточной 
коррекции схемы
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Создание проекта в среде Proteus
Соединение выводов /OE (Output Enable) 

регистров-защёлок с землёй
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Создание проекта в среде Proteus
Соединение выводов /OE (Output Enable) 

регистров-защёлок с землёй
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Создание проекта в среде Proteus

Подключение 
питания
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Создание проекта в среде Proteus

Окончательная схема 
управления светодиодным 

дисплеем
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Закрытие окна приветствия
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Необходимо убедиться в активной 
перспективе «C/C++» и, в 
противном случае, выбрать её из 
списка перспектив

Окно Eclipse после закрытия окна приветствия
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Если в качестве перспективы по умолчанию установлена 
«Java», а не «C/C++», она меняется нажатием на 
кнопку «Open Perspective» и выбором из прилагаемого 
списка требуемой перспективы. Ненужную 
перспективу «Java» можно закрыть нажатием на ней 
правой клавишей мыши и выбором пункта «Close» в 
появившемся меню
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Смена перспективы Кнопка «Open Perspective»

Список прилагаемых перспектив
(в будущем нам понадобятся две из 

них: «C/C++» и «Debug»)

Внимание! Если «C/C++» отсутствует 
в списке перспектив, её надо 

будет установить посредством 
соответствующего plug-in

cdt-master-x.x.x.zip
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Исходное состояние Eclipse

Перспективу «Java EE» можно 
закрыть путём нажатия правой 

клавиши мыши в её области и выбора 
пункта «Close» в появившемся меню



Импортирование
Eclipse-проекта на базе make-файла

27

Копирование в папку «MMVP» библиотек и готового проекта
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Добавление папки проекта с 
разработанной схемой

Шаг 1.
Начальная стадия 

импортирования проекта

File → Import
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Добавление папки проекта с разработанной схемой

Шаг 2.
Выбор типа 

проекта

General → 
Existing Projects 
into Workspace 

→ Next
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Добавление папки 
проекта с 

разработанной 
схемой

Шаг 3.
Указание пути к 
папке проекта

Select root directory: → 
Browse… → Выбор 

папки проекта

Внимание! Проект располагается в папке 
рабочего пространства, выбранного при 

запуске Eclipse как Workspace
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Добавление 
папки проекта с 
разработанной 

схемой

Шаг 4.
Результат 

указания пути 
к папке 
проекта

Finish
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Добавление папки проекта с 
разработанной схемой

Шаг 5.
Результат добавления проекта к 

рабочему пространству



Импортирование
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базе make-файла
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Построение проекта 
и генерация elf и hex 

файлов

Шаг 1.
Запуск построения проекта
(запуск цели all make-файла)

Главное меню
«Project → Build All 

(Ctrl+B)»
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Безуспешное построение проекта

Импортирование
Eclipse-проекта на базе make-файла

Если в окне «Console» появляется сообщение об ошибке вида 
-------- begin --------
arm-none-eabi-gcc -c -g -I. -D inline= -mthumb -mcpu=cortex-m4 
-O0 -T standalone.ld -ggdb main.c -o main.o
process_begin: CreateProcess(NULL, arm-none-eabi-gcc -c -g -I. 
-D inline= -mthumb -mcpu=cortex-m4 -O0 -T standalone.ld -ggdb 
main.c -o main.o, ...) failed.
make (e=2): Не удается найти указанный файл.

make: *** [main.o] Error 2

**** Build Finished ****
необходимо обратиться к следующему слайду; в случае успеха – к 
слайду 46
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Безуспешное построение проекта

Импортирование
Eclipse-проекта на базе make-файла

Если в окне «Console» появляется сообщение об ошибке вида 
-------- begin --------
arm-none-eabi-gcc -c -g -I. -D inline= -mthumb -mcpu=cortex-m4 -O0 -T standalone.ld -ggdb 
main.c -o main.o
process_begin: CreateProcess(NULL, arm-none-eabi-gcc -c -g -I. -D inline= -mthumb 
-mcpu=cortex-m4 -O0 -T standalone.ld -ggdb main.c -o main.o, ...) failed.
make (e=2): Не удается найти указанный файл.

make: *** [main.o] Error 2

**** Build Finished ****

Данная проблема может проявиться во время построения проекта
Существуют два пути устранения:
1. При наличии прав администратора – установка в переменной PATH 

операционной системы (см. слайды 36 – 38) пути к файлам
arm-none-eabi-gcc.exe, arm-none-eabi-ld.exe, arm-none-eabi-objcopy.exe,
arm-none-eabi-size.exe и обязательный перезапуск Eclipse

2. При отсутствии прав администратора – настройка окружения Eclipse
(слайды 39 – 45)
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Импортирование
Eclipse-проекта на базе make-файла
Коррекция переменной PATH при наличии прав администратора
Внимание! При установке ARM инструментария желательно закрыть Eclipse
Добавление пути к переменной PATH

Здесь нажать на 
правую клавишу 

мыши
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Импортирование
Eclipse-проекта на базе make-файла
Коррекция переменной PATH при наличии прав администратора

Добавление пути к 
переменной PATH
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Импортирование
Eclipse-проекта на базе make-файла
Коррекция переменной PATH при наличии прав администратора

Непосредственное добавление пути к переменной PATH

После повторного запуска Eclipse действия слайда 16 необходимо повторить
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Импортирование
Eclipse-проекта на базе make-файла
Коррекция переменной PATH при отсутствии прав администратора

Шаг 1.
Открытие 

диалога 
свойств 
проекта

Главное 
меню

«Project → 
Properties»
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Импортирование
Eclipse-проекта на базе make-файла
Коррекция переменной PATH при отсутствии прав администратора

Шаг 2.
Добавление 
к проекту 

переменной 
окружения

C/C++ Build → 
Environment → 

Add



4141

Импортирование
Eclipse-проекта на базе make-файла
Коррекция переменной PATH при отсутствии прав администратора

Шаг 3.
Добавление новой переменной окружения

New variable → 🗹Add to all configurations → Variables
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Импортирование
Eclipse-проекта на базе make-файла
Коррекция переменной PATH при отсутствии прав администратора

Шаг 4.
Добавление 
переменной 

Path 
окружения

Choose a variable 
→ Path → OK
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Импортирование
Eclipse-проекта на базе make-файла
Коррекция переменной PATH при отсутствии прав администратора

Шаг 5.
Именование добавленной переменной

Name: Path → OK



4444

Импортирование
Eclipse-проекта на базе make-файла
Коррекция переменной PATH при отсутствии прав администратора

Шаг 6.
Начало 

коррекции 
переменной 
Path в среде 

Eclipse

Environment → 
Path → Edit…
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Импортирование
Eclipse-проекта на базе make-файла
Коррекция переменной PATH при отсутствии прав администратора

Шаг 7.
Непосредственная коррекция переменной Path в среде Eclipse путём 

добавления к ней пути к компилятору и вспомогательному отладочному 
инструментарию

Edit variable → Value: …\GNU Tools ARM Embedded\4.6 2012q4\bin → OK



Успешное построение проекта

Импортирование
Eclipse-проекта на базе make-файла
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Формирование папки 
«Debug» с elf и hex 

файлами внутри

Безошибочное построение проекта



Успешное построение проекта

Импортирование
Eclipse-проекта на базе make-файла
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Формирование 
папки «Debug» с 

elf и hex 
файлами внутри

Безошибочное построение проекта



4848

Связь программного проекта в Eclipse 
со схемотехническим в Proteus

Шаг 1.
Вход в диалоговую панель 
редактирования свойств 

микроконтроллера



Шаг 2.
Выбор программного 

elf-файла
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Связь программного проекта в Eclipse 
со схемотехническим в Proteus
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Связь программного проекта в Eclipse 
со схемотехническим в Proteus

Искомый elf-файл внутри рабочего проекта 
«MMVP_LW1_ATSAM3N4C_LedDisplay», 

который принадлежит  рабочему 
пространству «MMVP»



Результат выбора 
программного elf-файла
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Связь программного проекта в Eclipse 
со схемотехническим в Proteus



Проверка корректности связи 
программного проекта в Eclipse со 

схемотехническим в Proteus

Шаг 1. Запуск модели
5252

Связь программного проекта в Eclipse 
со схемотехническим в Proteus
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Связь программного проекта в Eclipse 
со схемотехническим в Proteus

Проверка 
корректности связи 

программного 
проекта в Eclipse со 
схемотехническим в 

Proteus

Точка 
прерывания 

(F9)

Шаг 2. Контроль состояния 
отладочных и информационных окон



Лабораторная работа № 1 
завершена!
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Основы управления
средствами Eclipse
Устранение возможных семантических ошибок

Семантические ошибки – это «кажущиеся» 
ошибки, на которые указывает среда Eclipse, а не 
компилятор, при безошибочном построении 
проекта

Семантические ошибки связаны с тем, что среда 
не «видит» файлов, в которых определяются 
новые, «ошибочные» с точки зрения среды типы 
данных

Для устранения данных ошибок среде 
необходимо указать пути к исходным 
заголовочным файлам 55



Основы управления
средствами Eclipse

Устранение возможных семантических ошибок

Семантическая ошибка как ошибка, на 
которую указывает среда Eclipse при 
безошибочном построении проекта

56



Шаг 1. Выявление семантических 
ошибок

Основы управления
средствами Eclipse

Устранение возможных семантических ошибок

Семантическая ошибка как ошибка, на 
которую указывает среда Eclipse при 
безошибочном построении проекта

57



Основы управления
средствами Eclipse

Устранение возможных семантических ошибок
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Шаг 2. Переход к свойствам проекта



Шаг 3. Подготовка к указанию 
пути к стандартным 

библиотекам

Основы управления
средствами Eclipse

Устранение возможных 
семантических ошибок

59



Основы управления
средствами Eclipse

Устранение возможных семантических ошибок
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Шаг 4. 
Непосредственное 

указание пути к 
стандартной 
библиотеке



Результат устранения семантических ошибок

Основы управления
средствами Eclipse

Устранение возможных семантических ошибок
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Основы управления
средствами Eclipse
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Во избежание повторного 
прохождения длительного 
процесса настройки аналогичных 
проектов новые проекты 
настоятельно рекомендуется 
создавать на базе существующих 
путём копирования (Ctrl+C → 
Ctrl+V)



Шаг 1. Копирование 
текущего проекта в 

буфер обмена

Основы управления
средствами Eclipse

63



Шаг 2. Вставка 
скопированного 

проекта из буфера 
обмена

Основы управления
средствами Eclipse
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Основы управления
средствами Eclipse
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Шаг 3. Коррекция 
имени нового 

проекта



Шаг 4. Очистка 
нового проекта

Основы управления
средствами Eclipse
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Шаг 5. Коррекция 
имени нового 
проекта в его 
make-файле

Основы управления
средствами Eclipse
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Шаг 6. Построение 
нового проекта

Основы управления
средствами Eclipse

68



Шаг 7. Контроль 
безошибочного 

построения нового 
проекта

Основы управления
средствами Eclipse

69
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Дополнительные 
полезные 

настройки 
Eclipse-проекта

Шаг 1. Подготовка к настройке 
изменения свойства 

автоматического сохранения всех  
несохранённых файлов перед 

построением проекта
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Дополнительные 
полезные 

настройки Eclipse-
проекта

Шаг 2. Непосредственное 
изменение свойства 

автоматического 
сохранения всех  

несохранённых файлов 
перед построением проекта



Eclipse. Закрытие проекта 
производится нажатием 
правой клавиши мыши в 

области проводника «Project 
Explorer» проектов на 

названии проекта и выбором 
в появившемся меню пункта 

«Close Project»
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Eclipse. Удаление проекта 
из списка проектов 

производится нажатием 
правой клавиши мыши в 

области проводника «Project 
Explorer» проектов на 

названии проекта и выбором 
в появившемся меню пункта 

«Delete»
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Проводник Eclipse по 
программным объектам
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Блочный комментарий в Eclipse
Выделенный блок комментируется/раскомментируется комбинацией клавиш «Ctrl + /»
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Спасибо за 
внимание


