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Урок 01. Процесс конечно-элементного моделирования в Femap

Этот урок содержит общие принципы моделирования конструкций методом конечных элементов и обзор 
основных инструментов в Femap, доступных для создания FEA-моделей.

Темы урока:
• Что такое метод конечных элементов?
• Что включает в себя FEA-модель?
• Последовательность КЭ моделирования в Femap
• Объекты модели и команды Femap
• Обзор интерфейса Femap
• Единицы измерения
• Форматы файлов Femap
• Настройки Femap
• Лицензирование Femap
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Что такое метод конечных элементов?

Анализ конечных элементов (МКЭ) - это математическое моделирование поведения конструкции под 
действием внутренних или внешних сил, основанное на численных методах решения 
дифференциальных уравнений.

МКЭ можно использовать для моделирования следующих типов физического поведения:
• механика деформируемого твердого тела
• теплообмен
• гидродинамика
• оптические явления
• электромагнетизм

Femap with NX Nastran можно использовать для моделирования первых двух типов задач. Femap Flow, 
Thermal и Advanced Thermal могут использоваться для моделирования задач теплообмена, гидродинамики 
и оптики.
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Что включает в себя FEA-модель?

Модель конечно-элементного анализа представляет собой набор следующих объектов:
• Конечные элементы, которые определяются в зависимости от выбранной математической модели:

• Балочные элементы Beam и Rod
• Плоские элементы Plate, Laminate, Membrane – треугольные или прямоугольные, с линейной или 

квадратичной функцией формы.
• Объемные элементы Solid, Solid Laminate
• Различные элементы, такие как пружины, точечные массы, RBE и контактные

• Модели материалов – изотропные, 2D и 3D ортотропные, 2D и 3D анизотропные.
• Граничные условия (нагрузки и закрепления)

Любая FEA-модель будет настолько точно соответствовать действительности, насколько подробно вы ее 
аппроксимируете набором соответствующих объектов в Femap.
Точность результатов конечно-элементного анализа модели зависит от качества сетки, выбранной 
модели материала, граничных условий и типа анализа.
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Объекты Femap и рабочий процесс создания модели FEA
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Материалы

Свойства

Сетка

Граничные условия
• Закрепления
• Нагрузки

Анализ

Обработка результатов

Препроцессор

Выбор типа 
анализа и запуск 
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Визуализация и 
анализ 

результатов
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Объекты модели Femap и команды – Геометрия

Импорт геометрии Создание геометрии внутри 
Femap

Модификация геометрии

File > Import Geometry
File > References

Geometry > commands Geometry > commands
Modify > commands

Импорт напрямую геометрии САПР
Solid Edge, NX (Unigraphics и I-deas), ProE, CATIA и SolidWorks.

Поддержка стандартов обмена данными 3D-моделей
Parasolid, ACIS, IGES, STEP, STL

Создание и редактирование геометрии инструментами Femap
Точки, кривые в плоскости и трехмерном пространстве
Поверхности
Объемы
Серединные поверхности
Meshing Toolbox
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Объекты модели Femap и команды – Материалы и свойства КЭ

Типы материалов:
• изотропные
• 2D и 3D ортотропные
• 2D и 3D анизотропные
• Эластомеры
• Поддержка различных решателей (NX Nastran, 

MSC Nastran, LS-Dyna, Abaqus, Marc)

Материалы Свойства КЭ

Model > Material Model  > Properties

Типы КЭ:
• Балочные элементы
• Плоские элементы
• Объемные элементы
• «Остальные» элементы
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Объекты модели Femap и команды – Граничные условия

Для закреплений и нагрузок дерево проекта «Model Info» позволяет:
• Создание, редактирование, выделение и удаление полных наборов 

нагрузок и закреплений
• Создание, редактирование, выделение и удаление отдельных видов 

нагрузок и закреплений
• Создание и редактирование нагрузок и настроек Body, Nonlinear, Dynamic 

и Heat Transfer

Закрепления Нагрузки

Model > Constrain Model  > Load
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Объекты модели Femap и команды – Сетка

Дополнительные инструменты для создания и редактирования сетки 
доступны в Meshing Toolbox

Настройки сетки и разбиение 
геометрии Отдельно узлы Отдельно элементы

Mesh > Mesh Control
Mesh > Geometry

Model  > Node Model  > Element
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Объекты модели Femap и команды – Анализ

Создайте и отправьте анализ с помощью команды Model> Analysis

Панель инструментов PostProcessing Toolbox является основным интерфейсом 
для графического отображения результатов моделирования с помощью:
• Деформированного вида
• Отображение в различных графических режимах и векторном виде
• Создание и визуализация Freebody

Используйте таблицу данных и набор команд List > Output для создания таблицы 
результатов

Анализ Просмотр результатов Отчетность

Model > Analysis View > Select  (F5)
View > Options (F6)
View > Advanced Post

List > Output commands
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Обзор графических инструментов пользователя

Графический интерфейс Femap имеет несколько компонентов:
• Панель открытых в данный момент моделей

• Одновременно можно открывать и отображать несколько моделей
• Динамическое масштабирование, панорамирование и вращение осуществляется с помощью 

мыши• Выпадающие меню команд
• Панели инструментов – 

настраиваются пользователем
• Плавающие панели инструментов 

быстрого доступа – создаются и 
настраиваются пользователем

• Панель состояния Femap в нижней 
части графического окна
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Единицы измерения в Femap

Femap, как и большинство FEA-решателей не имеет единиц измерения.

Но…
• Стандартные материалы Femap и библиотеки сечений балочных КЭ используют единицы измерения 

дюймы-фунты
• Импортированная геометрия по умолчанию конвертируется в дюймы. Изменить единицы измерения 

импортированной геометрии можно в общих настройках Preference опцией Geometry Scale Factor
• Parasolid (независимо от программы) всегда хранит данные в метрах

Инструмент преобразования единиц позволяет пользователю преобразовывать единицы данных в 
модели

Пользователь должен знать о используемой системе единиц
• Вы можете использовать команду «File -> Notes», чтобы сделать примечание для справки в будущем и 

добавить комментарий в файл анализа.

Следующие две страницы имеют диаграммы, которые показывают согласованные значения единиц, 
которые должны использоваться для получения верных результатов.
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Единицы измерения для задач механики деформируемого 
твердого тела

Model Data
English

lbf – in- s
Metric

mN – mm - s
Metric

N – mm - s
SI

N – m - s

Length inches mm mm m

Mass Density  lbm/in3 kg/mm3 Tonnes/mm3 kg/m3

Force lbf mN N N

Stress, Pressure, Modulus of Elasticity, Shear 
Modulus

psi KPa MPa Pa

Moment,
Torque

lbf-in N-mm N-mm N-m

Velocity in/sec mm/sec mm/sec m/s

Acceleration in/sec 2 mm/sec2 mm/sec2 m/sec2

Temperature °F °C °C °C

Coefficient of Thermal Expansion in/degF mm/degC mm/degC m/degC
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Единицы измерения для термических задач

Model Data
English

lbf – in- s
Metric

mN – mm – s
Metric

N – mm – s
SI

N – m – s

Length inches mm mm m

Mass Density  lbm/in3 kg/mm3 Tonne/mm3 kg/m3

Temperature °F °C °C °C

Coefficient of Thermal Expansion in/°F mm/°C mm/°C m/°C

Energy lbf-in µJ mJ J

Thermal Conductivity lbf/sec-°F W/mm-°C W/mm-°C W/m-°C

Specific Heat lbf/sec2-°F µJ/kg-°C mJ/Tonne-°C J/kg-°C

Heat Transfer Coefficient lbf/in-sec-°F W/mm2 W/mm2 W/mm2

Heat Generation (Flux) lbf-in/sec W W W
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Преобразование единиц измерения

Используйте команду Tools > Convert Units для 
преобразования единиц измерения.
• Преобразование всех величин с использованием 

преобразования базовых единиц
• Преобразование определенных объектов с 

индивидуальными коэффициентами преобразования

Пример. Преобразуйте единицы N-мм в модель в N-m
Длина: 0,001 м = 1 мм
Масса: 1000 кг = 1 тонна
Сила: 1 N = 1 N
Энергия: 0,001 Н•м = 1 Н•мм 
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Форматы файлов Femap

Команды File > Save и File > Save As сохраняют файлы модели Femap в виде 
двоичных файлов .modfem
• Файлы Femap, сохраненные в версиях до Femap v10.2, хранятся в виде 

файлов с расширением .mod
• Femap автоматически преобразует файлы старой версии .mod или .modfem в 

текущую версию Femap
• Когда это преобразование происходит, вам предоставляется поле 

сообщения нейтрального файла Femap, затем диалоговое окно «Neutral File 
Read Option», в котором вы подтверждаете параметры для преобразования 
из старого файла модели.

• Используйте параметр ID Offset, чтобы избежать перезаписи существующих 
объектов в вашей модели Femap
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Форматы файлов Femap (продолжение)

Нейтральный файл Femap (расширение файла .NEU) является 
текстовым файлом Ascii и может быть экспортирован из Femap 
с помощью команды File > Export > Femap Neutral. 

• Эта команда позволяет вам написать нейтральный файл 
для более ранней версии Femap (v4.1 через текущую 
версию Femap).

• Нейтральные файлы используются для объединения 
моделей Femap.

• Объекты, не поддерживаемые в более ранней версии 
Femap, будут игнорироваться при записи нейтрального 
файла.
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Настройки Femap

Настройки Preference используются для 
оптимальной конфигурации 
производительности Femap и удобства работы. 
Они подробно описаны в руководстве Femap 
Commands и в онлайн-справке Femap.
• Настройки хранятся в файле femap.ini в 

основной папке установки Femap

Чтобы задать настройки, выберите команду 
«File» > «Preference»
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Диалоговое окно настроек Femap Preference

Настройки Preference имеют следующие вкладки
• Messages 
• Views
• Graphics
• User Interface
• Database
• Geometry/Model
• Interfaces
• Results
• Library/Startup
• Color
• Spaceball

Следующие слайды описывают три наиболее важные вкладки 
настроек Preferences: Geometry / Model, Graphics and Database
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Диалоговое окно настроек Femap Preference – 
коэффициент масштабирования Geometry Scale 
Factor

Выберите геометрическое ядро Parasolid или Standard для вашей модели Femap. Рекомендуется 
использовать ядро Parasolid, в противном случае можно импортировать, создавать или редактировать 
только геометрию каркаса.
Femap хранит геометрию в метрах. Коэффициент масштабирования Solid Geometry Scale Factor 
используется для внутреннего преобразования ваших геометрических единиц в метры в Parasolid.

• Например, если вы выбираете Inches, коэффициент 
масштабирования составляет 39,37 (дюймы/метр). 
Femap использует инверсию этого номера для хранения 
геометрии в своей базе данных моделей (1 дюйм = 
0,0254 метра).

• Это масштабирование позволит вам импортировать 
модели, которые находятся за пределами 
моделирования Parasolid (куб 1000 метров на каждую 
сторону, в центре 0,0,0 или +/- 500 метров в X, Y и Z) 
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Диалоговое окно настроек Femap Preference –
настройки графики 

Диалоговое окно «Графика» позволяет управлять настройками 
графики и настройками динамического вращения.
• Аппаратное ускорение может быть отключено, если 

графическая карта или ее драйверы вызывают нестабильность 
в Femap.

• Performance Graphics может использоваться только тогда, когда 
присутствуют видеоадаптеры, поддерживающие OpenGL 4.2 или 
выше.

• VBO могут использоваться, когда присутствуют видеоадаптеры, 
поддерживающие OpenGL 2.1 или выше.

• Включение меньше объектов из списка Include In Dynamic Rotation 
улучшит плавность динамического вращение больших моделей.

• Сообщения Advanced/Debug Messages могут быть включены, 
чтобы помочь команде разработчиков диагностировать сложные 
проблемы с геометрией, если они возникнут. 
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Диалоговое окно настроек Femap Preference –
Performance Graphics и VBOs

Включение параметра Performance Graphics может значительно 
повысить производительность на моделях с большим количеством:
• Объемных тел
• Точек
• Узлов
• Объемных и плоских элементов

Использование Vertex Buffer Arrays (VBOs) еще больше повышает 
производительность для моделей с включенной графикой или без 
нее.

Установите значение Max VBO MB не более 75% (%) от общей памяти 
видеокарты.
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При использовании Femap следует учитывать разрешение рабочего стола. Чем выше разрешение 
рабочего стола, тем труднее обрабатывать графические объекты.

Если у Femap появляются графические ошибки, причиной этому может быть драйвер для вашей 
видеокарты. Необходимо постоянно обновлять драйвера видеокарты.

• Драйверы от производителей чипсета графических карт, как правило, более стабильны, чем 
драйверы от производителя видеокарты. (например, используйте драйвер ATI или nVidia, а не драйвер 
ASUS)

• Вы также должны установить настройки производительности вашей видеокарты в режим по 
умолчанию. В некоторых случаях установка карты для оптимальной производительности для 
различных приложений может привести к сбою Femap.

Требования к производительности видеокарты
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На вкладке Data Base определяются различные параметры 
производительности :

• Параметры базы данных
• Производительность базы данных
• Срочное сохранение
• Каталог временных файлов

Нажмите кнопку «Справка по параметрам базы данных», чтобы 
получить подробную информацию о настройках на этой вкладке.
• Обратите внимание, что любые изменения, внесенные на 

вкладку Data Base, требуют выхода и запуска нового сеанса 
Femap.

Настройки Femap - База данных Data Base
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Этот параметр указывает местоположение файлов каталога 
Scratch, где во время сеанса Femap записываются временные 
файлы и файлы для восстановления.
• Если эта опция оставлена пустой, Femap будет записывать свои 

временные файлы в папку Windows TEMP
• Установка папки Femap Scratch или установка переменной TEMP 

в местоположение сетевого файла может серьезно ухудшить 
производительность Femap и значительно увеличить время 
сохранения файлов.

• Закройте и перезапустите Femap после изменения 
расположения папки Scratch Directory.

Настройки Femap – Scratch Directory
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Эти параметры указывают на:
• Ограничение памяти базы данных - устанавливает максимальный объем 

системной памяти, который FEMAP будет использовать для хранения частей 
модели и получения результатов из памяти.

• Max Cached Label - устанавливает самую большую метку, для которой FEMAP 
зарезервирует память. Этот параметр должен быть установлен на 
идентификатор, превышающий любой объект в модели.

• Значение по умолчанию – 99 999 999

Настройки Femap – Параметры производительности базы 
данных

• Blocks/Page - Оптимальная настройка этого числа часто зависит от скорости диска и контроллера. 
Значение по умолчанию «4» было определено с помощью тестирования для обеспечения наилучшей 
производительности в широком диапазоне значений для ограничения памяти базы данных и 
использования настроек по умолчанию для нескольких типов дисков. Вы можете попробовать другие 
значения от 1 до 15. Как правило, это должно быть полезно при использовании таких накопителей, как 
SSD.

• Open/Save Method - используйте для оптимизации производительности чтения/записи файлов Femap. 
Используйте тест чтения/записи, чтобы определить, какой метод будет работать лучше всего на вашем 
компьютере.


